V1 announces DbBACS support for the new BACS security.

From June 13 2016, BACS are introducing a new security certificate (SHA-256) and will only support TLS1.1/1.2.  V1 DbBACS customers need to take action now to prevent interruption to the BACS service they use. Please contact us to arrange an upgrade.

What Version of DbBACS is supported?

DbBACS IP Must be running 6.01.0131 to be compatible. 

What do these changes mean for DbBACS?

V1 and FGL are pleased to announce DbBACS currently supports the forthcoming changes (SHA-2 SSL certificates and TLS1.1/1.2) on supported operating systems. See below for further details. 

What do I need to do now?

Customers must identify whether their existing operating system and/or internet browser supports SHA-2 SSL certificates and TLS1.1/1.2.   

What is the minimum operating system?

Based on information from Microsoft, desktop operating systems before Windows 7 e.g. Windows XP, Windows Vista are not compatible.  

What is the minimum internet browser?

For connecting to the BACS Payment Services website outside of DbBACS, customers will also need a suitable browser version:

Browser

Default Support

Supported with configuration (and possibly O/S) changes

Microsoft Internet Explorer

From version 11

Versions 8, 9, 10

Google Chrome

From version 26

n/a

Mozilla Firefox

From version 27

From version 23 to 26

Apple Safari

From version 7

n/a

 What do you need to do next?

Scenario

Action

Operating system and web browser support SHA-2 SSL certificates and TLS1.1/1.2

 

No action required

Operating system and web browser DOES NOTsupport SHA-2 SSL certificates and TLS1.1/1.2

Upgrade to Windows 7 or later

Upgrade to a supported internet browser

Contact their Account Manager to determine whether V1 DbBACS needs upgrading.

 

Scroll to Top